A temporarily updated version of Ilhsiek's 'Much Needed' 1.5.0

Download any EFT version outside of its official way can get you banned.
If we find out that you downloaded EFT on a pirate website you'll be banned without further informations.

You need to own the game and keep it installed on your computer to play AKI.
Backup Escape From Tarkov 0.12.11.7.15261
2.0.* mods aren't working on 2.1.0.

This is a version of Ilhsiek's 'Much Needed' that I modified and temporarily updated.

[tabmenu]


Purpose :
I am just leaving this page up for people who want to use Ilhsiek's mod for 2.1.0.


Note :

[ I have modified a few things on this version ranging from armors, containers, meds etc... ]

[ All features have been disabled so you can pick and choose what you want. ]


I haven't noticed any problems with the features and things seem to be working fine so I figured I'll just leave this page up just until Ilhsiek updates his mod the right way. ^^

I have modified the 'God Stim' benefits a bit and added somewhat of a backstory, it's also more expensive & only acquirable at Level 4 Therapist.