Some BSG 12.12 new Items 2.0.1

Download any EFT version outside of its official way can get you banned.
If we find out that you downloaded EFT on a pirate website you'll be banned without further informations.

You need to own the game and keep it installed on your computer to play AKI.

Only contains some of BSG 12.12 new items

Please BACK UP YOUR PROFILE before using this mod!

WARNING: Items added in this mod have Unique IDs, if you planning to uninstall this mod, remember to delete items in this mod and USE IT AT YOUR OWN RISK


Items NOT included in this mod: new Armor/Plate Carrier, new cloth, new Face, MTs-255 revolver shotgun, MP-43 double barrel, Range Finders

Items currently doesn't work/malfunction: M18 Green Smoke Grenade, RGO/RGN impact grenade




Changelog:

  • Fixed Russian Locale
  • Fixed Keycard Holder Case storage
  • Fixed loading time issue by changing load order
  • Fixed Glock MOS slide position
  • Fixed SKS drum mag dependency


Credits: All modle/bundle file dumped from BSG 12.12, I only do the backporting work

Special THANKS to: Fin, Lua, SamSWAT for helping me with break profile issue
Thanks to: Dashwood#4526, Scootis_McPootis#1175, voltic#1739, Warbly#5811, zii.#3766 for testing!



USE THIS MOD AT YOUR OWN RISK

Kindly reminder to people who has break profile issue:

Quote



northeast007 
Yesterday, 10:07 am Author

The content is actually same. I'm not sure with file size, maybe I switched compress method in 7z? And for my opinion, if you got broken profile issue before, the best choice is not using this mod. But, if you really want to use. You can copy and paste your whole SPT-AKI folder along with client file into a different folder and then install this mod on that folder. If anything wrong, just delete the folder you created and this will have no impact on your original one :)

  • does this include supply drops

  • where do i download this file to get this to work, i tried downloading it in my mods file but still nothing..can anyone please share installation instruction

  • I've been trying to edit the magnifications of some of the optics in the mod to be a bit less extreme and more pleasing to use, however, I've found that attempting to change what magnifications the scopes have results in the value that shows what magnification you're set to changing to the edited value, but the actual magnification of the scope remains the same as the original without any changes.


    I'm not entirely sure if it is possible to change them, but I would assume that it would be possible since I have done these small edits without any issue before with the optics in Tarkov's base game files, maybe there's just some setting in the item files I'm overlooking?

  • can you fix this? id like to use it but its not usable

    Like 1
  • it contains lighthouse map too?

  • I got the mod to load, does anyone else have a cannot read "foldable" trace error? tried to reinstall the mod and the only other mod I have installed is the AllInOneMod and core.

  • my maps aren't loading in after installing this all the buildings are messed up

  • after I downloaded the mod, I got an infinite loading screen, does anyone know how to solve this problem?

    • Very likely it's a trace error. That's what I was getting yesterday. One of my mods (in my case Andruis QOL) was not compatible with this mod. This caused it to load for 15 minutes before going back to the main menu. I also got a corrupt profile and had to make a whole new SPT (which I new the risks before trying this). If you have multiple mods try just putting them in your mod folder one at a time with this mod until you find the problem or they are all in.

    • ok, thanks man, i will try that

  • Great mod! I've kept running the version from when you last uploaded it and updated it to this version today - no issues or anything so far


    Any chance you'll add the MPX/MCX stock adapter in the next version? The one that lets the MCX accept buffer tubes and things like that

  • fair warning this is still corrupting my profile on 12.12.... i thought making a new copy of my current singleplayer folder and playing it on that one would save my other folder from corruption...but apparently not. Just a heads up to others that had this issue as well last time.

    • Great reminder! I like it :)

      Apparently you didn't see my reply to adrian.ferrarini :

      Quote

      northeast007 Yesterday, 10:07 am Author

      The content is actually same. I'm not sure with file size, maybe I switched compress method in 7z? And for my opinion, if you got broken profile issue before, the best choice is not using this mod. But, if you really want to use. You can copy and paste your whole SPT-AKI folder along with client file into a different folder and then install this mod on that folder. If anything wrong, just delete the folder you created and this will have no impact on your original one :)

      I'm not sure what's your definition of "current singleplayer folder", but Please check:

      1. You copy and paste your WHOLE SPT-AKI folder along with your client file into a fully different folder
      2. Check the game path of your new copied folder in your launcher
    • No this is exactly what i did. but after the game started messing up i deleted the extra copy that i installed your mod into and tried to just play on my original spt folder and still was getting the trace error.

  • hi bro, very appriciate your work. i can't load the mod that it say missing the package.json
    how to fix it? i'm using aki 2.1.2 :D

    • Thanks for the feedback. You need to put the folder inside "BSG 12.12 new items V2.0.1" into your "user/mods" :)

    • i already put it in that folder but still can't load :(

    • oh i haven't read carefully. tks you very much :D love it

  • Thank you for the reupload. kanawowkanawowkanalovekanalovekanapatkanapat

    Thanks 1
  • Anyone else have an infinite loading screen on log in? Running AKI 2.0.0

    • your running aki 2.0.0. You need 2.1.2

    • Yes, i have it.

      Wait 5 minutes of loading

    • I get infinite loading but I'm on 2.1.2

  • why was the original 'content from 12.12' mod removed?

    • Broken profiles. Something the modder acknowledges is still possible.

    • oh ok

  • is lighthouse in this mod?

    • It's an items mod. And not all are in it due to features not in 12.11, such as the revolver shotgun.

      Thanks 1
  • Don't be offended, I'm just expressing my opinion... what are the risks, is it losing profile or something else. Actually it's a good mod, only a few items that can't keep grenades have problems too, it's the same as the previous mod.

    • thanks for the reply. This version is only a renamed version of previous one to fix some compatibility issue. And for me, the only situation I encountered is break profile. So always backup your profile

  • Thanks for the mod!


    Any chance the new clothes could be added in a later update?

  • Thanks for the mod, Quick question, however. Do the items spawn naturally in the world or do we have to purchase them from vendors?

    • That depends on what mod you have. But I'm sure that items added by this mod will not spawn on map. You can expect better experience on next release of spt-aki than a simple mod

    • sounds good

  • Is this a drop-in replacement for the last version? Can I simply just update to this one or do I have to remove the old one and it's items from my profile before I use this?

    • If previous version works for you, you have no need to download or update. For installation/uninstall, please regard to warning section

    • Ah, fair enough. Great mod btw, I persoanlly haven't experienced any issues with it.

    • Cool! Glad to hear. Then I guess You have no need to update this version

  • Works Like a charm :3


    thx for that work and thx to the helpers !




    btw. is inertia possible for SPtarkov at all ? sounds complicated to mod or am i wrong?

    <3

    • Yep. since inertia is not really an "item", you can expect this in next release of spt-aki

    • Hey, I have the newest version of SPT AKI, and have tried making a new save, etc etc, and cannot get past the profile loading screen, is there something im missing such as a specific way to install the mod... I will keep trying however i feel that I did something incorrect... does it install like a normal mod and can I use the MOD manager?

    • yes use it as normal mod in mods folder.

      Let it load on loading screen. It will take 5-6 Minutes to load for me, too. :)

  • Thanks for the port! Quick question though: is this the updated version of the previous 12.12 items upload from a few days ago? The file size seems smaller. Is the content the same? Thanks again :)

    • Great question, as he took down the previous one for profile corruption reports and compatibility issues of some sort.

      Hopefully, that's all fixed with this version as I want to use the things it has because SPT 12.12 is a LONG way off. But given the "USE THIS MOD AT YOUR OWN RISK" major warnings, I have reservations.

      Haha 1
    • The content is actually same. I'm not sure with file size, maybe I switched compress method in 7z? And for my opinion, if you got broken profile issue before, the best choice is not using this mod. But, if you really want to use. You can copy and paste your whole SPT-AKI folder along with client file into a different folder and then install this mod on that folder. If anything wrong, just delete the folder you created and this will have no impact on your original one :)

    • Thanks for the reply. Yep, I bet it was the compression, now that I think about it. And no, I had no problems so far, great job. I could only hope for the lighthouse map and the rangefinders, but I understand that there are game mechanics in there that are quite tough to get through, especially with the Rogues. But then again, it is already great as it is, thanks!

    • Thanks for your feedback!