KMC-CORE 3.0.2

Da core, which is required to run any KMC mods.

[tabmenu]



Check the ReadMe for more info.

Images

  • Version 3.0.2

    Fixed compatibility for modders, changed items.ts for future weapons.

  • Version 3.0.1

    Fixed _props error that stopped bots from spawning

  • Version 3.0.0

    Adds the following new ammo:

    84mm

    .500BLK

  • Version 1.3.1

    AKI 2.1.X Compat

    More Stat/Locale/Price and Loyalty changes

    Loot Spawner Module Removed

    Future versions will be packed with respective mods

    7.92 Kurz Icon corrected (Kinda)

    New Models for .50 Beowulf
    unknown.png



  • Version 1.3.0

    Loot Spawns actually fixed
    Requires Weapons 1.2.3 or higher to function properly

    Added 6.5 Creedmoor

    Added 8mm Mauser
    Sweeping Changes to Stats, Loyalty Levels and Prices
    Ammo boxes doe, more to come!

    Does *NOT* currently work AKI 2.1.0

  • Version 1.2.1

    The Loot Spawner Hotfix
    Exactly what it says on the tin.
    Shoud fix compat issue with other dynamic loot mods.
    Upgrade from 1.2.0

  • Version 1.2.0

    The Ammo Expansion
    +P and +P+ Rounds included for some calibers
    Vanilla Compatible
    World Spawns from some items on Customs

    Currently conflicts with Ereshkigal's AllOfficialKeys

    ---Added---

    - Glaser Blue Saftey Slug
    ---9x19, 10mm, .40SW, .357 Sig and .380 Auto


    -Dagny Dagger (Armor-Penetrating Hollow Point)

    ---9x19, 10mm, .40SW, .45 ACP, .357 Sig and .380 Auto


    -FMJ Flat Nose

    ---9x19, 10mm, .40SW, .357 Sig and .380 Auto


    -FMJ Ball/Round Nose

    ---10mm, .45ACP, and .357 Sig


    -High Velocity Soft Point

    ---10mm


    -Jacketed Soft Point

    ---.50AE


    -Jacketed Hollow Point

    ---9x19, 10mm, .40SW, .45 ACP, .50AE, .50BW, .357 Sig and .380 Auto


    -Incendiary

    ---.45 ACP


    -RIP and +P RIP

    ---9x19, 10mm, .40SW, .45 ACP, .357 Sig and .380 Auto


    -Red Tracer

    ---9x19, .40SW, and .380 Auto


    -Xtreme Defender

    ---9x19, 10mm, .40SW, .45 ACP, .50AE .357 Sig and .380 Auto


    -Xtreme Penetrator

    ---9x19, 10mm, .40SW, .45 ACP, .50AE .357 Sig and .380 Auto




    Current Ammo Chart is here






    Ammo Loyalty Levels and prices subject to change based on feedback

    --Huge Thanks to:

    TwistedGA for the sick Texture work
    Stealthsuit for helping me place worldSpawns
    Nerds like you that actually want to use content I've had a hand in creating

  • Version 1.1.3

    New stuff!!

    ____Additions_____

    --Added .40 FMJ
    --Added Grendel Incendiary
    --.380 ACP added

    --.50 BW added for MCACW Expansion (.50 BW Requisitioned with permission from KCH Armory)

    -- Added .357 RIP and Green Tracer
    -- .357 GT is identical to FMJ but its a tracer
    -- All .357 Craftable at workbench using corresponding 10mm FMJ and the corresponding 9x19 round,
    (e.g.: Round Pliers + 10MM FMJ + 9x19 GT = .357 GT
    )


    Other things I'm probably forgetting!

    _____Changes and Removals_____

    -Some fancy new custom bundles for our bullets thanks to TwistedGA
    *(not all of them are finished, more to come)
    --Grendel HE changed to Grendel Frag (Needs tweaks, pls gib feedback)
    -- .357 Grizzly HP Damage/bleed chances reduced, pen/muzzle velocity increased
    -- .357 FMJ damage increased, muzzle velocity decreased

    -- Slight Buffs across the board for 10mm, Grendel and .277


    -Removed duplicate pen chance probabilities from all Grendel rounds

    NEW AMMO CHART INBOUND

  • Version 1.1.2

    -Corrected Grendel FMJ Weight


    -10mm FMJ now available at Gospozha LL1 (Craftable at Workbench 3)


    -.40 S&W FMJ now available at Gospozha LL1 (Craftable at Workbench 3)


    -6.8 TVCM AP Damage 68 >>> 72
    -6.8 TVCM AP Muzzle Velocity 1050 >>> 1103 (~30% increase vs .308 M61)
    -6.8 TVCM AP moved to Gospozha LL4 (Craftable at Workbench 3)


    -6.8 TVCM FMJ Damage 70 >>> 75

    -6.8 TVCM FMJ Pen 45 >>> 49
    -6.8 TVCM FMJ Muzzle Veloctiy 968 >>> 1024 (~23% increase vs .308 M80)

  • Version 1.1.1

    - Corrected Ammo Stats (Armor damage was represented as a 0 - 1)
    -Added .40 S&W FMJ
    -Added hideout crafts for some ammo, check em out and gib feedback! They all populate at the bottom, so no need to look for em!

  • Update - 11/16/2022

    I'm still alive but development of the mod has been paused so that I can focus on my studies in college. I haven't abandoned the mod, and there's no ETA on when I will release an update, but I plan to release an update when I feel like I've reached a good enough point. Personally, I'd prefer if people could leave the mod alone for now, I'd rather not hand it over to someone else. I'm hoping to try and push something during winter break when my college semester ends.


    For those wondering, current reasons why I haven't pushed out an update of what I've already achieved is mostly due to the following:

    Some custom weapons are missing audio

    Some textures could be polished/I'm not really proud of it

    Some guns aren't finished or are bugged

    A lot of minor stuff that I want completed aren't done yet (custom ammo, attachments for custom weapons, etc).

    Uniforms/clothing not having the right FPS hands
    Custom bullet stats unfinished or missing things

    Helmet attachment overhaul unfinished

    Thumbs Up 2
    • take ur time bro, cant wait for this to finally drop

  • hella confused ive tried everything to straight renaming files for compliance but nothing i do seems to work.


    The application had a critical error and failed to run

    Exception produced: Error: Cannot find module '../../KMC-Core/src/_api/KMCapi.js'

    Require stack:

    - C:\SPTARKOV\user\mods\KMC-Gear\src\script.js

    - C:\SPTARKOV\user\mods\KMC-Gear\package.js

    - C:\snapshot\project\obj\loaders\PreAkiModLoader.js

    - C:\snapshot\project\obj\controllers\GameController.js

    - C:\snapshot\project\obj\callbacks\GameCallbacks.js

    - C:\snapshot\project\obj\di\Container.js

    - C:\snapshot\project\obj\Program.js

    - C:\snapshot\project\obj\ide\ReleaseEntry.js

    1) If you want to compile the package/file into executable, please pay attention to compilation warnings and specify a literal in 'require' call. 2) If you don't want to compile the package/file into executable and want to 'require' it from filesystem (likely plugin), specify an absolute path in 'require' call using process.cwd() or process.execPath.


    Stacktrace:

    Error: Cannot find module '../../KMC-Core/src/_api/KMCapi.js'

    Require stack:

    - C:\SPTARKOV\user\mods\KMC-Gear\src\script.js

    - C:\SPTARKOV\user\mods\KMC-Gear\package.js

    - C:\snapshot\project\obj\loaders\PreAkiModLoader.js

    - C:\snapshot\project\obj\controllers\GameController.js

    - C:\snapshot\project\obj\callbacks\GameCallbacks.js

    - C:\snapshot\project\obj\di\Container.js

    - C:\snapshot\project\obj\Program.js

    - C:\snapshot\project\obj\ide\ReleaseEntry.js

    1) If you want to compile the package/file into executable, please pay attention to compilation warnings and specify a literal in 'require' call. 2) If you don't want to compile the package/file into executable and want to 'require' it from filesystem (likely plugin), specify an absolute path in 'require' call using process.cwd() or process.execPath.

    at Function.Module._resolveFilename (node:internal/modules/cjs/loader:933:15)

    at Function._resolveFilename (pkg/prelude/bootstrap.js:1955:46)

    at Function.Module._load (node:internal/modules/cjs/loader:778:27)

    at Module.require (node:internal/modules/cjs/loader:1005:19)

    at Module.require (pkg/prelude/bootstrap.js:1855:31)

    at require (node:internal/modules/cjs/helpers:102:18)

    at Object.<anonymous> (C:\SPTARKOV\user\mods\KMC-Gear\src\script.js:13:16)

    at Module._compile (node:internal/modules/cjs/loader:1105:14)

    at Module._compile (pkg/prelude/bootstrap.js:1894:32)

    at Object.Module._extensions..js (node:internal/modules/cjs/loader:1159:10)


    couldnt find any other post about this so i decided to post my own

    • im trying to run KMC-WEAPONS 3.0.1 and KMC-gear 1.1.2 aswell.

    • why are you trying to run kmc-gear, did you not read the tag on it?

  • thx for fixing compatibility with modders

  • The link for 3.0.2 seems to link to a file named 3.0.1

  • Version 3.0.2 download links to 3.0.1 zip?

    • yes, didn't change the file version because I didn't want to reupload KMC-Weapons

      Thumbs Up 1
  • ModLoader: loading 51 mods...

    Mod aleves-alevesthings is not compatible with the current version of AKI. You may encounter issues - no support will be provided!

    Mod CWX-MasterKey is not compatible with the current version of AKI. You may encounter issues - no support will be provided!

    Mod jenwalter-Loot Randomiser is not compatible with the current version of AKI. You may encounter issues - no support will be provided!

    Mod JoshJ5Hawk-LootBoxes is not compatible with the current version of AKI. You may encounter issues - no support will be provided!

    Mod JoshJ5Hawk-SuperLoot is not compatible with the current version of AKI. You may encounter issues - no support will be provided!

    Mod KMC-WEAPONS requires KMC-CORE version . Current installed version is 3.0.1

    Mod Kobrakon-UltimateClearNVGs is not compatible with the current version of AKI. You may encounter issues - no support will be provided!

    Mod Mira-M16A4-Remake is not compatible with the current version of AKI. You may encounter issues - no support will be provided!

    Mod EmuRC-GhostFenixx-SVM is not compatible with the current version of AKI. You may encounter issues - no support will be provided!

    Mod Arokar-TacticoolReplacers is not compatible with the current version of AKI. You may encounter issues - no support will be provided!

    Mod Virtual-Virtuals Custom Quests Loader is not compatible with the current version of AKI. You may encounter issues - no support will be provided!

    Mod DeadW0Lf-balancedmeds is not compatible with the current version of AKI. You may encounter issues - no support will be provided!

    Mod DeadW0Lf-usefulfoodsanddrinks is not compatible with the current version of AKI. You may encounter issues - no support will be provided!

    Errors were found with mods, NO MODS WILL BE LOADED


    emmmm BTW im using 3.0.1 for both MOD

  • Hello, I love this mod so much so far. One question though.. Where and what is the .json that contains Gospozha's trader level? Profile editor doesn't recognize that it has more than one level, so its either im stuck buying shtuff till I get there and/or I patiently await an answer lol ^^:lolivodka:

  • HELP?

    The application had a critical error and failed to run

    Exception produced: Error: Cannot find module '../../KMC-Core/src/_api/KMCapi.js'

    Require stack:

    - S:\Games\SP TARKAS\user\mods\KMC-Gear\src\script.js

    - S:\Games\SP TARKAS\user\mods\KMC-Gear\package.js

    - C:\snapshot\project\obj\loaders\PreAkiModLoader.js

    - C:\snapshot\project\obj\controllers\GameController.js

    - C:\snapshot\project\obj\callbacks\GameCallbacks.js

    - C:\snapshot\project\obj\di\Container.js

    - C:\snapshot\project\obj\Program.js

    - C:\snapshot\project\obj\ide\ReleaseEntry.js

    1) If you want to compile the package/file into executable, please pay attention to compilation warnings and specify a literal in 'require' call. 2) If you don't want to compile the package/file into executable and want to 'require' it from filesystem (likely plugin), specify an absolute path in 'require' call using process.cwd() or process.execPath.

    • which version are you using (both the mod and spt itself)?

  • Mod (KMC-WEAPONS-3.0.1) is missing package.json


    i have both kmcs in user/mods folder core trader shows ingame with ammo just no kmc weapons. elp

  • TypeError: Cannot read properties of undefined (reading '_props')

    TypeError: Cannot read properties of undefined (reading '_props')

    at BotEquipmentModPoolService.generatePool (C:\snapshot\project\obj\services\BotEquipmentModPoolService.js)

    at BotEquipmentModPoolService.generateWeaponPool (C:\snapshot\project\obj\services\BotEquipmentModPoolService.js)

    at BotEquipmentModPoolService.getCompatibleModsForWeaponSlot (C:\snapshot\project\obj\services\BotEquipmentModPoolService.js)

    at BotEquipmentModGenerator.getDynamicModPool (C:\snapshot\project\obj\generators\BotEquipmentModGenerator.js)

    at BotEquipmentModGenerator.chooseModToPutIntoSlot (C:\snapshot\project\obj\generators\BotEquipmentModGenerator.js)

    at BotEquipmentModGenerator.generateModsForWeapon (C:\snapshot\project\obj\generators\BotEquipmentModGenerator.js)

    at BotWeaponGenerator.generateWeaponByTpl (C:\snapshot\project\obj\generators\BotWeaponGenerator.js)

    at BotWeaponGenerator.generateRandomWeapon (C:\snapshot\project\obj\generators\BotWeaponGenerator.js)

    at BotInventoryGenerator.addWeaponAndMagazinesToInventory (C:\snapshot\project\obj\generators\BotInventoryGenerator.js)

    at BotInventoryGenerator.generateAndAddWeaponsToBot (C:\snapshot\project\obj\generators\BotInventoryGenerator.js)

    TypeError: Cannot read properties of undefined (reading '_props')

    TypeError: Cannot read properties of undefined (reading '_props')

    at BotEquipmentModPoolService.generatePool (C:\snapshot\project\obj\services\BotEquipmentModPoolService.js)

    at BotEquipmentModPoolService.generateWeaponPool (C:\snapshot\project\obj\services\BotEquipmentModPoolService.js)

    at BotEquipmentModPoolService.getCompatibleModsForWeaponSlot (C:\snapshot\project\obj\services\BotEquipmentModPoolService.js)

    at BotEquipmentModGenerator.getDynamicModPool (C:\snapshot\project\obj\generators\BotEquipmentModGenerator.js)

    at BotEquipmentModGenerator.chooseModToPutIntoSlot (C:\snapshot\project\obj\generators\BotEquipmentModGenerator.js)

    at BotEquipmentModGenerator.generateModsForWeapon (C:\snapshot\project\obj\generators\BotEquipmentModGenerator.js)

    at BotWeaponGenerator.generateWeaponByTpl (C:\snapshot\project\obj\generators\BotWeaponGenerator.js)

    at BotWeaponGenerator.generateRandomWeapon (C:\snapshot\project\obj\generators\BotWeaponGenerator.js)

    at BotInventoryGenerator.addWeaponAndMagazinesToInventory (C:\snapshot\project\obj\generators\BotInventoryGenerator.js)

    at BotInventoryGenerator.generateAndAddWeaponsToBot (C:\snapshot\project\obj\generators\BotInventoryGenerator.js)



    Not sure if anyone having issue, bots will not spawn with mod installed

    • what version of the mod are you using, and what version is your spt

    • spt is 3.4.1 and i had 3.0.0, just updated it now i cannot even load into the game anymore, just loading profile data forever

      Heart 1
    • any different error after you've updated ?


      you most definitely are doing something wrong, follow the install instructions make sure the mod folder is "KMC-CORE" and "KMC-WEAPONS" both uppercase like i just wrote them.

  • Oh my god it finally happened

  • Error also with the version 3.5.0 and with the 3.4.1

  • Not complaining just trying to give input but upon opening the trader and scrolling down game crashes

    • Known issue that I’m not sure how to fix. Just allow your icons to load slowly and the crashes will stop.

  • man i'm finna throw a party when this mod updates

  • any idea of how to fix this:

    Stacktrace:

    ReferenceError: Logger is not defined

    at new KMCcore (C:\SPT\user\mods\KMC-Core\src\script.js:25:9)

    at Object.<anonymous> (C:\SPT\user\mods\KMC-Core\package.js:5:22)

    at Module._compile (node:internal/modules/cjs/loader:1105:14)

    at Module._compile (pkg/prelude/bootstrap.js:1894:32)

    at Object.Module._extensions..js (node:internal/modules/cjs/loader:1159:10)

    at Module.load (node:internal/modules/cjs/loader:981:32)

    at Function.Module._load (node:internal/modules/cjs/loader:822:12)

    at Module.require (node:internal/modules/cjs/loader:1005:19)

    at Module.require (pkg/prelude/bootstrap.js:1855:31)

    at require (node:internal/modules/cjs/helpers:102:18)

  • Having a small issue on server startup. Just a little curious if anyone has a fix for me.

  • Do you have a Discord server? Or anywhere where we could maybe keep tabs on how development is going? I really love the mod and I hope to see it re release sometime soon!

    • I do, but it's temporarily closed because there's not really much work going on - I'm focusing on college, trying to pass my classes so I can get into the major I want. It'll be reopened when I get the time to mod again.

  • does work for 2.2.2?

    • Yes, it will work with any version before 3.0.0

  • Can't wait for the new version!Hope KMC mods for 3.0.0.

  • Is there any plans to update this for the newer versions of SPT?
    retardadothinking

    • yes

    • ok thanks for the info!

    • There's no ETA, but developing KMC has always been going on and we plan to make a new release in the future

    • Could you tell us how far you went in terms of updating? Not asking for a date, just how far you went with updating

    • currently core, gear, and weapons is updated to 3.0.0 and is being tested. Still stuff being worked on before I'm satisfied with releasing an update

      Thanks 1 Happy 2
  • Found a fix for those getting the "trader id DOC_TRADER not found, back to default refresh time of 3600"


    Add this after line 52 in KMC-Core/SRC/script.js


    let DOC_TRADERRefresh = {"traderId": "DOC_TRADER","seconds": 3600}

    TraderConfig["updateTime"].push(DOC_TRADERRefresh);

    • Looks like it worked, now, let's see how I can fix the crash that happens as soon as I open the trader lol

    • Oof, I never had that problem, good luck.

  • Do you plan on updating the mod at all along with any other mods in conjunction with this one?

  • Why does doge appear on non modded items? https://i.imgur.com/kFwQXbz.jpg

    • usually happens when there's a duplicate CAB ID, the 25mm ring will be fixed in a new version, but idk what happened to the ultima as I've never used any part of it

    • Ahh ok. thank you!

  • if i tried to start the server, it just says "trader id DOC_TRADER not found, back to default refresh time of 3600"

    what should i do here

    • it's just an error, but it should work just fine.

    • its just that the launcher wont stop loading after i get that message

    • what do you mean?

    • but thank you nonetheless

      i thought it was something more game breaking than just a normal error

    • basically after the server thing loaded i launched the AKI launcher but it wont stop loading

  • 2.3.1, still working, great

  • I realized I posted this in gear instead of core- But anyway, I changed the Aki version in the package file and now its saying that it is missing a file. I kinda need help . .


    unknown.png

    • did you delete the json or something

    • Sorry for very late reply but i saw the problem haha. I was coding smth wrong.

  • update will be? for 2.3.1

  • is there any mod your mods dont work with that you know of bc my game keeps crashing after i buy something from your trader

    • Unfortunately I'm not too certain as I don't really use other mods

  • awesome mod been enjoying it for a bit now but i was curious if the is a way to see the ammo stats, as in pen and dam of them?

  • imagine not updating


    cringe

    Like 1
  • Does exactly what it says

    I mean, it just stays there. You download it and that's it, you install it and bam, it just works. What does it do you ask? No idea. We don't need to know, we just need to read the fine print, play, report bugs and that's all, anything else is superflous.

    DON'T ASK QUESTIONS. MOVE ALONG.

  • Worth using (still works for 2.3.1 btw)

    Insanely good mod, lots of guns, one small issue is that the deagle is for some reason double action, and reflections on it are kind of weird, but aside from that the mod is very fun to play around, does not affect performance and the guns feel great.

  • Really damn good mod

    This mod and KMC gear+weapon are really good, Desert Eagle is kinda scuffed tho


    I'll be waiting for the 3.0.0 update :senkosmug:

    Reply from The_Katto ():

    Desert Eagle recoil is being reworked, we're still messing around with the shaders/textures to see what works best <3

  • The core mod to some wack ass banger mods

    This mod is the core for the other 2 katto mods, and is pretty fucking pog